Total de visualizações de página

Pesquisar este blog

terça-feira, 22 de março de 2011

PEIXE URBANO

Olá, para aqueles que quiserem me ajudar a ganhar uma renda extra, basta clicar no link abaixo:

https://www.peixeurbano.com.br/convite/4QOJQ

Trata-se do peixe urbano, veja que o protocolo é HTTPS então não tenham medo de clicar.

Obrigado Junior.

quarta-feira, 16 de março de 2011

DICA EXCEL "SOMASE"

Olá, hoje vamos ver mais uma poderosa função do Excel onde podemos "somar" celular utilizando um critério. Image assim, você tem que somar todos os títulos de um cliente em uma base de 10 mil linhas mas nao quer utilizar os métodos tradicionais como por exemplo o sub-total com filtros. Então vamos a mão na massa.

Descrição:
Use a função SOMASE para somar os valores em um intervalo (intervalo: duas ou mais células em uma planilha. As células de um intervalo podem ser adjacentes ou não adjacentes.) que atendem aos critérios que você especificar. Por exemplo, suponha que em uma coluna que contém números, você deseja somar apenas os valores maiores que 5. É possível usar a seguinte fórmula:

=SOMASE(B2:B25,">5")

Exercício Prático: SOMASE
Na tabela abaixo queremos somar todos os códigos 100 com seus respectivos valores. Sendo assim, sempre que aparecer o valor 100 na minha coluna de COD. o Excel vai somar de maneira automática os valores no total.


Sintaxe da Função:
SOMASE(intervalo, critérios, [intervalo_soma])
  • intervalo: Necessário. O intervalo de células que se deseja calcular por critérios. As células em cada intervalo devem ser números e nomes, matrizes ou referências que contêm números. Espaços em branco e valores de texto são ignorados.
  • critérios: Necessário. Os critérios na forma de um número, expressão, referência de célula, texto ou função que define quais células serão adicionadas. Por exemplo, os critérios podem ser expressos como 32, ">32", B5, 32, "32", "maçãs" ou HOJE(). Importante: Qualquer critério de texto ou qualquer critério que inclua símbolos lógicos ou matemáticos deve estar entre aspas duplas ("). Se os critérios forem numéricos, as aspas duplas não serão necessárias.
  • intervalo_soma: Opcional. As células reais a serem adicionadas, se você quiser adicionar células diferentes das especificadas no argumento de intervalo. Se o argumento intervalo_soma for omitido, o Excel adicionará as células especificadas no argumento intervalo (as mesmas células às quais os critérios são aplicados).
Outras Aplicações Práticas:
Essa função aqui na empresa utilizo para preencher uma planilha de telefonia com 200 linhas, onde necessito saber qual a quantidade de equipamentos do modelo X.

Planilha de controle de Telefonia:
Formulas utilizadas:
=SOMASE($E$8:$E$213;E219;$B$8:$B$213)
=SOMASE($E$8:$E$213;E220;$B$8:$B$213)
=SOMASE($E$8:$E$213;E221;$B$8:$B$213)
=SOMASE($E$8:$E$213;E222;$B$8:$B$213)
=SOMASE($E$8:$E$213;E223;$B$8:$B$213)
=SOMASE($E$8:$E$213;E224;$B$8:$B$213)

Note que o intervalo e intervalo_soma são os mesmos por se tratar da mesma tabela. O que muda é somente o critérios, onde eu digo para o Excel na função SOMASE o que eu quero que ele some.

Bom pessoal como sempre tentei ser o mais objetivo possível para que não aconteça como acontecia comigo, muita teoria e pouca prática.

Mas caso ainda tenha dúvidas só postar no blog que irei responder dentro do meu conhecimento o que for possível.

Grato Junior.

quinta-feira, 3 de março de 2011

DICA EXCEL: O Poder do "PROCV"

Olá, hoje vamos ver uma ferramenta poderosa do Excel a função PROCV. Mas o que significa o PROCV? Então, o PROCV significa "procura na vertical", ou seja se você quer procurar algum valor em uma determinada tabela sem necessitar fazer nada manual. Vamos imaginar o seguinte, seu diretor pede que você pegue os dados dos clientes da Matriz e compare com os clientes cadastrados na Filial. Pergunto, você vai imprimir um relatório de ambas e ir "ticando" um a uma até que chegue no resultado para ele? Você está rindo? Então pare, porque já vi casos reais assim aqui na empresa!!! Bom chega de papo e vamos a prática:

Digamos que você importou um texto do seu sistema de Gestão de sua Matriz com a seguinte nomenclatura:
CNPJ | COD.CLI | RAZAO SOCIAL

E outro da sua Filial com a mesma nomenclatura.
CNPJ | COD.CLI | RAZAO SOCIAL

Agora vamos entender como o PROCV funciona:
=procv(valor_procurado;matriz_tabela;núm_índice_coluna;[procurar_intervalo])

Campos:
procv = função procura na vertical
matriz_tabela = onde eu quero procurar os dados
núm_índice_coluna = o código da coluna que você quer mostrar. Exemplo: A B C, se você quer os valores que estão na C digite 3, se for B digite 2, e assim por diante.
procurar_intervalo = quando tratamos de valores que estejam em tabelas do tipo:
De | Ate | Valor, deixe o campo vazio. Caso for procurar um valor específico digite um ";" no final da função


Na figura 1 um erro Clássico que ficamos nos batendo um monte pra achar sendo que é somente um ";" que nos atrapalha. Veja que na figura 2 temos o #N/D

Veja que depois que tiramos o ";" ele funciona. Mas porque? Então o ";" serve para o PROCV achar valores exatos. Agora você deve estar se perguntando mas porque toda essa história se queremos comprar um cliente na base Matriz com o Filial? Foi propositado essa história para que você aprenda o PROCV não simplesmente faça por fazer.

Agora vamos ao "exercício" proposto:

Estou comparando os clientes da Filial x Matriz onde eu queria saber se na Filial eu tinha os clientes cadastrados na Matriz. Veja que com um comando eu fiz isso. Agora e se tivesse 10 mil registros pra você procurar?

A formula usada foi:
=PROCV(E3;A2:C7;3;)

Onde:
PROCV = função
E3 = é o cnpj na FILIAL
A2:C7 = é onde eu vou procurar no caso na tabela cnpj, cod, nome da MATRIZ
3 = a coluna que eu quero que imprima no meu resultado, no meu caso optei pelo nome, mas poderia ser qualquer campo.

Bom, tentei ser o mais breve e simples possível, dúvidas sobre a mesma postem no Blog que vou responder todas as dúvidas.

Abraço a todos, Junior.