Total de visualizações de página

Pesquisar este blog

quinta-feira, 3 de março de 2011

DICA EXCEL: O Poder do "PROCV"

Olá, hoje vamos ver uma ferramenta poderosa do Excel a função PROCV. Mas o que significa o PROCV? Então, o PROCV significa "procura na vertical", ou seja se você quer procurar algum valor em uma determinada tabela sem necessitar fazer nada manual. Vamos imaginar o seguinte, seu diretor pede que você pegue os dados dos clientes da Matriz e compare com os clientes cadastrados na Filial. Pergunto, você vai imprimir um relatório de ambas e ir "ticando" um a uma até que chegue no resultado para ele? Você está rindo? Então pare, porque já vi casos reais assim aqui na empresa!!! Bom chega de papo e vamos a prática:

Digamos que você importou um texto do seu sistema de Gestão de sua Matriz com a seguinte nomenclatura:
CNPJ | COD.CLI | RAZAO SOCIAL

E outro da sua Filial com a mesma nomenclatura.
CNPJ | COD.CLI | RAZAO SOCIAL

Agora vamos entender como o PROCV funciona:
=procv(valor_procurado;matriz_tabela;núm_índice_coluna;[procurar_intervalo])

Campos:
procv = função procura na vertical
matriz_tabela = onde eu quero procurar os dados
núm_índice_coluna = o código da coluna que você quer mostrar. Exemplo: A B C, se você quer os valores que estão na C digite 3, se for B digite 2, e assim por diante.
procurar_intervalo = quando tratamos de valores que estejam em tabelas do tipo:
De | Ate | Valor, deixe o campo vazio. Caso for procurar um valor específico digite um ";" no final da função


Na figura 1 um erro Clássico que ficamos nos batendo um monte pra achar sendo que é somente um ";" que nos atrapalha. Veja que na figura 2 temos o #N/D

Veja que depois que tiramos o ";" ele funciona. Mas porque? Então o ";" serve para o PROCV achar valores exatos. Agora você deve estar se perguntando mas porque toda essa história se queremos comprar um cliente na base Matriz com o Filial? Foi propositado essa história para que você aprenda o PROCV não simplesmente faça por fazer.

Agora vamos ao "exercício" proposto:

Estou comparando os clientes da Filial x Matriz onde eu queria saber se na Filial eu tinha os clientes cadastrados na Matriz. Veja que com um comando eu fiz isso. Agora e se tivesse 10 mil registros pra você procurar?

A formula usada foi:
=PROCV(E3;A2:C7;3;)

Onde:
PROCV = função
E3 = é o cnpj na FILIAL
A2:C7 = é onde eu vou procurar no caso na tabela cnpj, cod, nome da MATRIZ
3 = a coluna que eu quero que imprima no meu resultado, no meu caso optei pelo nome, mas poderia ser qualquer campo.

Bom, tentei ser o mais breve e simples possível, dúvidas sobre a mesma postem no Blog que vou responder todas as dúvidas.

Abraço a todos, Junior.
Postar um comentário